Personal tools
Home R├Ątsch Lab Supplements Online Quantitative Transcriptome Analysis Oqtans Installation Instructions

Oqtans Installation Instructions

Instructions for downloading and installation of Oqtans.

Easy install (default location & standard systems)

The easiest way of installing oqtans is to install it in the path /mnt/oqtansTools in a linux system that is supported (currently ubuntu-12.04 and redhat-6.3):

  • Install necessary system packages (see list below)

  • obtain oqtans and compile binaries

    cd /mnt/oqtansTools

    DISTNAME=<distribution-name-version>

    git clone git://github.com/ratschlab/oqtans_dep.git

    cd oqtans_dep ; git checkout ${DISTNAME} ; cd ..

    git clone git://github.com/ratschlab/oqtans.git

    cd oqtans ; ./oqtans_make.sh ; cd ..

    alternatively, one can download the releases:

    cd /mnt/oqtansTools

    DISTNAME=<distribution-name-version>

    wget http://ftp.raetschlab.org/software/oqtans/oqtans_dep-0.1-beta-${DISTNAME}.tar.bz2

    tar xjvf oqtans_dep-0.1-beta-${DISTNAME}.tar.bz2

    cd oqtans_dep ; git checkout ${DISTNAME} ; cd ..

    wget http://ftp.raetschlab.org/software/oqtans/oqtans-0.1-beta-${DISTNAME}.tar.bz2

    tar xjvf oqtans-0.1-beta-${DISTNAME}.tar.bz2

    cd oqtans ; git checkout ${DISTNAME} ; cd ..

    in all cases, the string "<distribution-name-version>" has to be replaced with one of the available system names (e.g., osx-10.7.4, ubuntu-10.04, ubuntu-12.04, redhat-6.3).

  • Add /mnt/oqtansTools/oqtans/oqtans_config.sh to your ~/.bashrc

  • Add the content of /mnt/oqtansTools/oqtans/tool_conf.xml.oqtans to your galaxy's tool_conf.xml file.

  • Add oqtans package to galaxy:

    cd /mnt/galaxyTools/tools (default, otherwise see tool_dependency_dir in universe_wsgi.ini)

    mkdir oqtans

    cd oqtans

    ln -s /mnt/oqtansTools/oqtans/package default

    ln -s /mnt/oqtansTools/oqtans/package 0.1

  • source ~/.bashrc and restart your galaxy instance.

  • Oqtans tools should be usable now within your galaxy instance.

local-deploy.png

Custom install (other locations and other systems)

  • Install necessary system packages (see list below)

  • obtain oqtans and compile binaries

    cd <oqtans-dir>

    git clone --recursive git://github.com/ratschlab/oqtans.git

    alternatively, one can download the releases:

    cd <oqtans-dir>

    DISTNAME=<distribution-name-version>

    wget http://ftp.raetschlab.org/software/oqtans/oqtans_dep-0.1-beta-${DISTNAME}.tar.bz2

    tar xjvf oqtans_dep-0.1-beta-${DISTNAME}.tar.bz2

    cd oqtans_dep ; git checkout ${DISTNAME} ; cd ..

    wget http://ftp.raetschlab.org/software/oqtans/oqtans_src-0.1-beta.tar.bz2

    tar xjvf oqtans_src-0.1-beta.tar.bz2

    cd oqtans_dep ; git checkout master ; cd ..

    wget http://ftp.raetschlab.org/software/oqtans/oqtans-0.1-beta.tar.bz2

    tar xjvf oqtans-0.1-beta.tar.bz2

    cd oqtans ; git checkout master ; cd ..

    in all cases, the string "<distribution-name-version>" has to be replaced with one of the available system names (e.g., osx-10.7.4, ubuntu-10.04, ubuntu-12.04, redhat-6.3).

  • Modify <oqtans-dir>/oqtans/oqtans_conf.sh to reflect the new oqtans root directory.

  • Compile and commit dependencies

    cd oqtans_dep ; git checkout -b <distribution-name-version> ; cd ..

    cd oqtans_src ; ./oqtans_make.sh ; cd ..

    cd oqtans_dep ; git commit -m "compiled oqtans_src for <distribution-name-version>" -a ; cd ..

    cd oqtans ; ./oqtans_make.sh ; cd ..

  • Add <oqtans-dir>/oqtans/oqtans_conf.sh to your ~/.bashrc

  • Add the content of <oqtans-dir>/oqtans/tool_conf.xml.oqtans to your galaxy's tool_conf.xml file.

  • Add oqtans package to galaxy:

    cd /mnt/galaxyTools/tools (default, otherwise see tool_dependency_dir in universe_wsgi.ini)

    mkdir oqtans

    cd oqtans

    ln -s <oqtans-dir>/oqtans/package default

    ln -s <oqtans-dir>/oqtans/package 0.1

  • source ~/.bashrc and restart your galaxy instance.

  • Oqtans tools should be usable now within your galaxy instance.


Individual tool installation

If one is only interested in a specific tool, then it can be easier to only install the specific tool. Here are a few notes:

  • A list of tools together with ways of obtaining them is given here.
  • A significant fraction of the tools are available on github.
  • A major dependency of rDiff, rQuant, mTIM is octave. If the linux distribution provides an octave package, then this one can be used in most cases for rDiff and rQuant (most distributions only provide a 32bit version, which limits the size of matrices and the programs may fail, in particular mTIM).
  • We currently prepare the installation of individual tools via the galaxy toolshed. Once galaxy supports fully automated tool installations we will start to support installation of oqtans tools via the toolshed.

Cloud installation

We prepared Oqtans to run in the cloud. Please follow instantiation instructions.


Updates

We will provide bugfixes to Oqtans tools via github. They can be obtained by:

cd oqtans; git pull ; cd ..

cd oqtans_dep; git pull ; cd ..

cd oqtans_src; git pull ; cd ..

cd oqtans_src; git pull ; cd ..

We will also include new versions of tools in future versions. To enhance reproducibility, we will keep older tool versions.


Required linux packages

  • ubuntu 10.04 or 12.04

    make gcc g++ git libhdf5-lam-1.8.4 libfontconfig1 libgl1-mesa-glx libglu1-mesa libreadline5 libgfortran3 gfortran libqrupdate1 python-dev pkg-config libncurses5-dev libreadline-dev libltdl-dev libpcre3-dev libhdf5-serial-dev gnuplot libidn11-dev cmake m4 help2man texinfo texlive python2.6 (or python2.7) libcholmod1.7.1 libcurl4-openssl-dev libglu1-mesa-dev libfltk1.3-dev libfreetype6-dev libgraphicsmagick1-dev libgraphicsmagick++3 libgraphicsmagick++1-dev libfontconfig1-dev

  • redhat 6.3

    pkgconfig python-devel make gcc gcc-c++ cmake m4 texlive-latex texinfo texinfo-tex libtool-ltdl-devel pcre-devel libgfortran gcc-gfortran bison bison-runtime automake bison-devel readline-devel ncurses-devel zlib-devel help2man numpy-f2py python2.6 (or python2.7)

  • Mac OS X (Macports packages with system python 2.7)

    py27-scipy py27-numpy help2man git-core gcc46 texlive m4 cmake texinfo R pkgconfig libpng g95 qhull pcre gnuplot fltk-devel hdf5 readline-5 qhull GraphicsMagick wget fftw-3-single hdf5-18

    also set the gcc compiler to gcc46: sudo port select --set gcc mp-gcc46

Document Actions